Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: 500-error on install

500-error on install 7 years 1 week ago #19674

  • marting
  • marting's Avatar Topic Author
  • Visitor
  • Visitor
Hi,

I'm trying to install DT register 3.0.0 (downloaded 12/01/13) and get the error below on install.

I have Community Builder 1.9, Joomla 3.0.2.
An error has occurred.

500 SQL=INSERT INTO `j30_comprofiler_tabs` VALUES ('', 'Payment Information', 'This information is used for online payments on this website.', 107, 10, '.5', 1, NULL, NULL, 1, '', 0, 'tab', 'cb_tabmain', -2);

Please Log in or Create an account to join the conversation.

500-error on install 7 years 1 week ago #19675

  • dthadmin
  • dthadmin's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 5470
  • Thank you received: 3
Hi.

Can you create a support ticket so we can debug this? Sorry you are having this issue.

Best Regards,
Rich
DTH Development

Please Log in or Create an account to join the conversation.

500-error on install 6 years 11 months ago #19755

  • Mickelain
  • Mickelain's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 0
I ran into this problem also. The query is missing a column (the second to last column).

Here is the query it attempts:
INSERT INTO `j30_comprofiler_tabs` VALUES ('', 'Payment Information', 'This information is used for online payments on this website.', 107, 10, '.5', 1, NULL, NULL, 1, '', 0, 'tab', 'cb_tabmain', -2);

Here is the table it's inserting into:
http://i.imgur.com/fLtk6MU.png

As you can see, the second to last column is missing. I just changed the query to this:
INSERT INTO `j30_comprofiler_tabs` VALUES ('', 'Payment Information', 'This information is used for online payments on this website.', 107, 10, '.5', 1, NULL, NULL, 1, '', 0, 'tab', 'cb_tabmain', 1, -2);

and ran it myself....... and it worked!

Note: I had to do it on one more INSERT statement too.

Please Log in or Create an account to join the conversation.

500-error on install 6 years 11 months ago #19762

  • tknight
  • tknight's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 0
For those of you who are upgrading from a lower version of Joomla to Joomla 3.0.2 this fixed my problem also. Thank you very much for the great fix!

The structure for joomla pre 3.0 uses the jml extention, not j30 - so just insert into jml_comprofiler_tab instead of the j30_comprofiler_tab.

Like this:
INSERT INTO `jml_comprofiler_tabs` VALUES ('', 'Payment Information', 'This information is used for online payments on this website.', 107, 10, '.5', 1, NULL, NULL, 1, '', 0, 'tab', 'cb_tabmain', 1, -2);

Just out of curiosity - what other values did you insert?

Please Log in or Create an account to join the conversation.

500-error on install 6 years 11 months ago #19763

  • Mickelain
  • Mickelain's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 0
I just added the second-to-last value for the viewaccesslevel column (you can see it in my screenshot above). All of them were 1, so I tried it with a 1 and it worked.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.075 seconds