Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Relay Response

Relay Response 5 years 6 months ago #22852

  • jstratos
  • jstratos's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 99
  • Thank you received: 1
Anyone know how to create a Thank You page for j1.5 when users are redirected back to the website using the SIM payment method for authorize.net?

The relay response URL used in the new SIM plugin "components/com_dtregister/success.php?task=restore" does not display any content to reassure the user that the transactions was successful from authorize.net.

We are getting this error message when users are using IE on a PC after completing their payment:
[attachment=0:ljnpzf07]<!-- ia0 -->Capture Error Message.PNG<!-- ia0 -->[/attachment:ljnpzf07]

No emails have been received advising of any errors as stated in the message? The transaction records are being saved to DTR.

We do not have the same issues using Firefox as the browser.

In A follow-up:
Authorize.net referred me to this post on their website regarding a Relay Response Time-out:
http://support.authorize.net/authkb/index?page=content&id=A663

Just to verify, this is what we are using for the Relay Response at Authorize.net without the quotes:
"our-domain-name/plugins/system/success.php?task=restore"

This is used as the RR for the SIM plugin:
"our-domain-name/components/com_dtregister/success.php?task=restore"
Attachments:

  • Rendering Error in layout Attachment/Item: Property "protected" is not defined. Please enable debug mode for more information.

Please Log in or Create an account to join the conversation.

Relay Response 5 years 6 months ago #22858

  • jstratos
  • jstratos's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 99
  • Thank you received: 1
I took a gamble and added authorize.net to the SQL remote access in cpanel and ran another test. No errors!

Now I just need to create the Thank You page? Any thoughts?

Please Log in or Create an account to join the conversation.

Relay Response 5 years 6 months ago #22866

  • nathan.dth
  • nathan.dth's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 1857
  • Karma: 19
  • Thank you received: 218
Hello! To confirm... you only have this issue for IE users?? As you resolved the error, what do you now see after a registration and payment?

Please Log in or Create an account to join the conversation.

Nathan is no longer affiliated with DTH since the recent acquisition. You can connect with him and get any type of Joomla website help at www.JoomlaEmployee.com .

Relay Response 5 years 6 months ago #22867

  • jstratos
  • jstratos's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 99
  • Thank you received: 1
Yes, only for IE when tested using version 11.0.9 on Windows 7. No issues with Firefox, but remember that this is in j1.5 only.

The page I get now for both browsers is the website header and navigations, no content for the main content (just a bit of white space), and then the footer.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.108 seconds