Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Fee Field stopped working

Fee Field stopped working 6 years 2 months ago #20745

  • jtjohnson
  • jtjohnson's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 4
  • Thank you received: 0
I was setting up several registrations with a fee change based off of a checkbox field. If the checkbox is checked, there is an additional fee applied to the total. I tested the functionality and everything seemed to work just fine. I then proceeded to set up the additional events and had everything set to go. I just assumed it was all working as I tested, but today I was just informed that the total fees are not changing when the checkbox is checked. Upon testing this discovery, I found that when I check the checkbox, it appears to "do the work", however the event fee amount does not change. Is there anything you can think of that might have caused the fee field to stop working like this. As far as I am aware, nothing has been done to the site. I know for a fact that it was working when I tested it. I don't know what to really do about it now.

Please Log in or Create an account to join the conversation.

Fee Field stopped working 6 years 2 weeks ago #21351

  • nathan.dth
  • nathan.dth's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 1857
  • Karma: 19
  • Thank you received: 218
Hello and sorry for the delay here. Not sure if you're still having an issue or not, but wanted to follow up. There is not any functionality in DT Register (or any other extension) that would just stop working all on its own of course. Something has to have been done... or not done.

I would recommend opening and re-saving your checkbox field after verifying the setup of the field is still correct. Then open and re-save each event that is using it. This in itself may provide essentially a "reset" to make sure all settings and fee structures for the events are saved properly.

If you still have an issue, submit a ticket with details on which field and which event we can replicate it on. We'll check out your setup from there.

Of course, make sure you have the latest version of DT Register in place also as older versions are not supported. Support at all for Joomla 1.5 sites is already very limited and near extinction. :) Thanks!

Please Log in or Create an account to join the conversation.

Nathan is no longer affiliated with DTH since the recent acquisition. You can connect with him and get any type of Joomla website help at www.JoomlaEmployee.com .

Fee Field stopped working 5 years 8 months ago #22140

  • Dansterpower
  • Dansterpower's Avatar
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 33
  • Thank you received: 0
Joomla 2.5.16 and DTRegister3_0_5


Posting here in the Joomla 1.5 thread to continue this previous discussion.

Just encountered this exact same issue as the thread starter.

Fee fields are not working in Checkboxes.

Fee fields were/are working perfectly in Drop Downs.

Joomla 2.5.16 and DTRegister3_0_5_dev_UNZIP

Tried the following:
Cleared all caches
Unpublished Field & Event
Created New Simple Checkbox Field with Fee.

Moving to a new site installation to attempt to replicate.

Dante

Please Log in or Create an account to join the conversation.

Last Edit: by Dansterpower.

Fee Field stopped working 5 years 8 months ago #22141

  • Dansterpower
  • Dansterpower's Avatar
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 33
  • Thank you received: 0
Joomla 2.5.16 and DTRegister3_0_5


Posting here in the Joomla 1.5 thread to continue this previous discussion.

Update:

The new site installation has all the same base level extensions as the malfunctioning installation; it also runs the exact same version of Joomla and DT Register.

In the new installation, both Checkboxes and Radio Buttons work properly; the fee is added to the total. Success happens regardless if the Checkbox or Radio button is a conditional field or not.

The difference with the malfunctioning installation rests in the shear number of DT Register Custom Fields, the number of Conditional Fields, and in the amount of custom html/css, and some light 'on-click' scripting that has been added to some of the fields.

This is likely a 'ghost in the machine' issue where some Javascript, css or html is interfering with the Checkboxes and Radio buttons. All other fee field types work fine.

We're building out some very complex instances of registration with DT Register; we'll report back if we learn more.

Best advice - when building complex installations of Joomla and DT Register pull backups every hour or so and test often - this will allow one to revert back to stable builds and will aid in tracking down bugs.

If we find the cause of this bug, we will report back.

Thanks,

Dante & company.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.103 seconds