Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: [SOLVED] Changing a field to Fee Field not working

[SOLVED] Changing a field to Fee Field not working 8 years 5 months ago #12907

  • jgitta
  • jgitta's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 2
  • Thank you received: 0
This may be a bug.
Add a field and save it.
Reopen the field and change it to a fee field.
The fee is not applied.
When you copy and rename the field the fee field will work.

Also: Is there a limit to how many fields can be on a form. I can only display 15 fields for an event.

Please Log in or Create an account to join the conversation.

[SOLVED] Changing a field to Fee Field not working 8 years 5 months ago #12956

  • wbaccus
  • wbaccus's Avatar
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 20
  • Thank you received: 0
Same issue here... Hope there's a quick fix for this one.

Please Log in or Create an account to join the conversation.

[SOLVED] Changing a field to Fee Field not working 8 years 5 months ago #12968

  • dthadmin
  • dthadmin's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 5470
  • Thank you received: 3
I am unable to replicate this problem guys. Make sure you have the latest version in place... and also make sure:

- you check the fee field check box
- enter a fee for EACH value. Just like selection limits, if you have 4 values (for example), you should have 4 fees... even if some are 0.

Also, try another browser... just thinking of anything that may be getting in your way. I just checked and verified this using Firefox. What browser are you using? Version of DT Reg?

If you can't get past this, submit a ticket so we can see it on your site and try to replicate it there.

Please Log in or Create an account to join the conversation.

[SOLVED] Changing a field to Fee Field not working 8 years 5 months ago #12970

  • jgitta
  • jgitta's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 2
  • Thank you received: 0
Using Firefox but wouldn't work in IE either. The problem seems to be when you set up a field and save it as a non fee field. Then go back and change it to a fee field and it will not charge the fee. Recreate it by copying it and the new field will charge the fee.

Can't open the site for testing right now because it is a live site.

Will advise.

What about the limit of only being able to display 15 fields in the events configuration?

Please Log in or Create an account to join the conversation.

[SOLVED] Changing a field to Fee Field not working 8 years 5 months ago #12971

  • dthadmin
  • dthadmin's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 5470
  • Thank you received: 3
Will test further, but thus far can't replicate it doing what you said here.

Regarding the limit, there is most definitely NOT a limit on how many fields you can use. We've seen DT Register users with crazy numbers of fields :) No limit is setup in the code either.

When you are on the fields tab in the event management, be aware that conditional fields will NOT show. Only the top level fields show up... when the top level field is enabled for an event, any lower level fields (conditional) are auto-enabled for the event. So not needed to show there. I'm assuming this is what you are seeing... expecting to see the conditional fields, but they're not there.

No limits though.

Please Log in or Create an account to join the conversation.

[SOLVED] Changing a field to Fee Field not working 8 years 5 months ago #12974

  • steve30000
  • steve30000's Avatar
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 106
  • Thank you received: 0
I can kind of confirm this bug although I'm finding something slightly different. I can't get the fee field to apply unless I change the field settings within the Specific Event away from Default. I am using 2.7.4 (updated from 2.7.3).

Steps to reproduce:
1) In backend, create a drop down field titled Test Fee.
2) Apply values of 10|20|30 with selection limits of 0|0|0
3) Check Fee Field and apply fees of 10|20|30. Fee type: Amount.
4) Default Settings: All Events-Yes, Show-Individual, Required-Yes, Group Registrations-Each Member
4) Save field
5) In frontend, go through registration form as individual and make selection in Test Fee field of 10, 20, or 30. The expected fee is not added.
6) In backend, select the particular event and then select Fields.
7) For "Test Fee" in "Used for this event?", select "Individual" (or "Both"). Something besides default.
8) Save field
9) Go through registration process again and fee is applied correctly.

In doing this testing with 2.7.4, I can't get a fee field to work unless I go into the individual event and change away from the Default option for that particular field.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
  • 2
Time to create page: 0.108 seconds